XTS 3000 RSM No audio

Post Reply
User avatar
Dubs
Posts: 11
Joined: Tue Jan 10, 2017 3:21 pm

XTS 3000 RSM No audio

Post by Dubs » Mon Oct 23, 2017 1:26 pm

Hey guys I'm a little confused on this one. I have two XTS 3000s which have been used successfully with speaker mics in the past without issue. However this last weekend I go to run the RSM off them and neither work. I've been setting them up for an XTVA so both had the RF adapter on them so I thought "Huh, the 3000 doesn’t pass audio with the adapter on there….that can be right." Sure enough they don't work without the Rf adapter either. So I loaded an earlier code plug to see if it could be programming related but still no audio (still not convinced it's not programming.) I run an ear piece (BDN6676D and a TCI listen only earpiece, As well as a stock Motorola surveillance 3.5mm) that I tend to hot swap with the radio on. Could I have smoked something on the board or ribbon doing that? I use the earpiece with a motorola brand 3.5mm threaded plug to the two pin listen only and then the tci 2 pin ear piece, which still seems to work great. I assumed the two pin design is the same between the two which still works, but perhaps not and that damaged something. The speaker mic's 3.5 mm threaded plug is not passing audio nor is the 3.5 plug on the head.

The issues persists for all my mics, commanders and standard alike. PTT works, mic works. Said RSMs work with other radios, works with the bdn7767 setup, XTVA works. Any ideas or things I can test would be much appreciated. I cleaned the contacts with an eraser and they seems to be in good condition, I'm kind of tapped out at this point, and it's more about finding out why rather than having them work with the RSMs. Thanks in advance guys.
User avatar
Notarola
Site Admin
Posts: 769
Joined: Fri Jan 13, 2017 5:30 pm

Re: XTS 3000 RSM No audio

Post by Notarola » Mon Oct 23, 2017 4:20 pm

check the radio contacts for corrosion. if I remember correct the radios use the MTSX series RSMs. Pin 2 is the external speaker and pin 6 is speaker common. I believe that pin 5 is pulled high to enable to external speaker.

I have the DSM if you need it.
[paypal]Donate[/paypal]
User avatar
Dubs
Posts: 11
Joined: Tue Jan 10, 2017 3:21 pm

Re: XTS 3000 RSM No audio

Post by Dubs » Mon Oct 23, 2017 7:16 pm

Well I'm embarrassed... The radio contacts looked shiny and clean (in fact cleaner than most of my 5ks) before and after i used an eraser on them, and it didn't help. However I have a steel pick in my drawer that comes in handy and decided to give them a light scraping and it's working now. I really didn't see that coming. So maybe moral of the story is just because they look clean doesn't mean they are, and or use contact cleaner. Thank you Notarola. Nailed it right off the bat even when I claimed I already "cleaned" them.
User avatar
Notarola
Site Admin
Posts: 769
Joined: Fri Jan 13, 2017 5:30 pm

Re: XTS 3000 RSM No audio

Post by Notarola » Tue Oct 24, 2017 4:25 pm

Experience lots and lots of experience. Glad to have helped.
[paypal]Donate[/paypal]
Post Reply